더북(TheBook)

B.2.7 특정 버전 설치

시간이 지나면서 내가 만든 프로그램이 특정 버전의 모듈에서만 동작하는 상황이 발생합니다. 이때는 @<버전>을 입력하면 원하는 버전을 설치할 수 있습니다.

mysql 모듈의 2.1 버전을 설치하겠습니다. npm install mysql@2.1을 입력합니다.

특정 버전 설치

> npm install mysql@2.1

microservice@1.0.0 C:\Users\microservice

-- mysql@2.1.1</p> <p class="txts cd">  +-- bignumber.js@1.0.1</p> <p class="txts cd">  +-- readable-stream@1.1.14</p> <p class="txts cd">  | +-- core-util-is@1.0.2</p> <p class="txts cd">  | +-- inherits@2.0.3</p> <p class="txts cd">  | +-- isarray@0.0.1</p> <p class="txts cd">  |– string_decoder@0.10.31

  `– require-all@0.0.3


 

모듈의 최신 버전이 궁금하다면 view 명령어를 사용합니다.

최신 버전 확인

> npm view mysql version

2.15.0


신간 소식 구독하기
뉴스레터에 가입하시고 이메일로 신간 소식을 받아 보세요.